BlackBerry Forums Support Community
              

Closed Thread
 
Thread Tools
Old 09-18-2007, 05:55 AM   #1
Paul Bowles
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Kent, UK
Model: Bold
PIN: N/A
Carrier: Orange
Posts: 83
Default Bluetooth Problems with OS after 4.2.0

Please Login to Remove!

I work for a company that makes bluetooth products and as such I get lots of bluetooth products to play with and also have a large choice of phones and PDA's to test them on.

Since we have launched a GPS unit we have seen that there is definitely a problem with the bluetooth in some versions of the 4.2 software and I would like to track down exactly what versions are effected.

Effected devices
Potentially all devices using 4.2 software. Seems mainly to effect Curves though (this could just be due to the amount of users that have Curves though).

The problem seems to be one of two things:
The BlackBerry either loses the Bluetooth connection (but still shows as paired) or it loses the settings for what service the device uses.

I have tested this with both our own products and similar products made by competitors and found the same issues with all of them which leaves it as a problem with the BlackBerry (also confirmed by other users on this forum). The same devices have also been tested and work fine on older BlackBerry's (4.1) and various Pocket PC's.

How this presents itself:
The problem is intermittent so often you will pair a device and it will initially work but then it will randomly stop working.

With a bluetooth GPS receiver (any brand) most GPS software will say there is no Satellite signal or the signal is too weak, however the GPS unit will indicate that it has a satellite signal but that the bluetooth connection is not active.

With a Bluetooth keyboard this presents itself as the keyboard appearing to be connected but then not working or it being constantly in the "connecting" phase. When checking the device properties you will often see that nothing is present under "Services:"

With Handsfree kits/headsets: Not been able to test this fully but I have a suspicion that the bluetooth issue may effect Address book transfers as well as randomly disconnecting the handsfree kit. If anyone has had these kind of problems I would like to hear about them.

What I would like to know:
If you have had these sorts of problems please let me know what model BB you have, what you are connecting to it and what version operating system your BlackBerry has (to find this go to Options/Settings on the application then go to about. You should see something like V4.2.2.803).

Short term fixes
I have not seen anything from RIM regarding this which is why I'm trying to gather as much information as I can. We have worked with RIM in the past on similar problems so once there is something we can work with I can pass it on to them.

Until that happens though there are a couple of short term fixes that may or may not resolve the problem:
  1. Disable the Bluetooth on the BlackBerry and Re-enabled it.
  2. Go into Options/Settings, then bluetooth, highlight the device from the list and then go to properties. In here press the menu button and select "Refresh Service List".
  3. Depending on the device changing the encryption to disabled and trusted to Yes may resolve the problem (I do not recommend disabling encryption for any device that could transmit private information such as keyboards, handsfree kits, etc).
  4. Reset the BlackBerry by pulling the battery and putting it back again.
  5. Install an older version of the BlackBerry operating system on the device. 4.2.0 appears to have no bluetooth problems at all and reverting back to this has fixed the issue for everyone I know who has tried it so far. This seems to also be the only fix that works in the long term. That being said if you do this make sure you back everything up first and make sure you know what you are doing.

So in short if you are having bluetooth issues with the 4.2.X BlackBerry's please let me know (should have just written that one sentence in the first place ).

Last edited by Paul Bowles; 09-18-2007 at 05:56 AM..
Offline  
Old 09-18-2007, 02:14 PM   #2
John Clark
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,720
Default

Paul,
I have encountered this issue many times using both of my GPS receivers and it's quite frustrating. I have the BT-359 and the Freedom Mini (I like my Freedom Mini the best, and use it the most BTW!)

This problem appears in all of the 4.2.1 versions of the Pearl handheld code. I have tried to gather information on this as to whether the Curve 4.2.2 OS is affected but haven't had any reports myself. I did find out from a couple other developers here on this forum that it is an issue with the RIM OS Bluetooth stack. 4.2.0 definitely is a fix for the issue. I would revert back to it myself if I didn't have a 4GB media card I need support for from 4.2.1. In my opinion, the 4.2.1 handheld code (at least for the Pearl) has serious bugs. This is one of them and the multi-tap doubling letters (even though I rarely use it except for passwords) and memory issues are the other major issues that RIM has neglected to fix.

Here is a thread that may shed some light on the subject.

http://www.blackberryforums.com/gps-...-software.html

I would be surprised if RIM wasn't aware of this problem. One would think that TeleNav support would have had lots of calls on this issue, as well.

Between this issue, the multi-tap issue, and memory issues the Pearl has been quite a headache. Now it appears that 4.2.2 code for the Curve has the same problem and RIM hasn't fixed it. I hope you can get them to fix this issue.

Last edited by John Clark; 09-18-2007 at 02:16 PM..
Offline  
Old 09-19-2007, 03:36 AM   #3
Paul Bowles
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Kent, UK
Model: Bold
PIN: N/A
Carrier: Orange
Posts: 83
Default

I can confirm the problem is there on the Curves with V4.2.2.67 have also had at least one customer with a V4.2.2.68 device that had problems also.

The strange thing is I have two here, both with the same software (V4.2.2.67), same carrier, etc and one always has bluetooth problems and the other so far has been rock solid. Don't know if this actually proves anything though as one (the one with the flaky Bluetooth) seems to get more use then the other.
Offline  
Old 09-19-2007, 09:57 AM   #4
lilitiki
Thumbs Must Hurt
 
Join Date: Jun 2007
Model: 8300
PIN: N/A
Carrier: at&t
Posts: 93
Default

v4.2.2.114 on the Curve. I'm using the Freedom Mini... (telenav, GM, BBmaps)

Same issues as described.

thanks.
Offline  
Old 09-19-2007, 10:04 AM   #5
John Clark
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,720
Default

I'm going to sticky this thread for a while. If enough people post that they are having a problem maybe RIM will work to get it fixed. It drives me nuts sometimes just trying to get a route from TeleNav.
Offline  
Old 09-19-2007, 10:36 PM   #6
luphongq23
New Member
 
Join Date: Sep 2007
Model: 8300
PIN: N/A
Carrier: att
Posts: 1
Default BB curve bluetooth connection problem

paul

i have the same problem with my bluetooth function with the curve. It disconnects from my handsfree (jawbone) if i talk on it for >20 mins. It is very frustrating!!! just got the phone
SW version v4.2.289

/mike
Offline  
Old 09-20-2007, 07:36 AM   #7
Paul Bowles
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Kent, UK
Model: Bold
PIN: N/A
Carrier: Orange
Posts: 83
Default

One thing that would be useful and I haven't had time to find is a link to the 4.2.0 OS. Anyone got one?
Offline  
Old 09-20-2007, 10:56 AM   #8
John Clark
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,720
Default

Paul, there is no 4.2.0 for the Curve but you can probably still get it for the Pearl. The link below should help. You'll need to sift through each carrier's downloads to find the version you want. IMO, the best OS for the Pearl was the 4.2.0.71. There should still be a carrier or two with that version.

BlackBerry Operating System Downloads - BlackBerryFAQ
Offline  
Old 09-21-2007, 04:10 AM   #9
Paul Bowles
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Kent, UK
Model: Bold
PIN: N/A
Carrier: Orange
Posts: 83
Default

ahh that would explain why I couldn't find it

Thanks John.
Offline  
Old 09-24-2007, 01:27 PM   #10
cjk1026
New Member
 
Join Date: Jan 2005
Location: Manhattan Beach, California
Model: Curve
Carrier: Verizon
Posts: 13
Default

My Verizon 8830 seems to have the above issue when using my GPS (Freedon Mini). What a pain in the rear! Any help fixing this would be greatly appreciated.

Thanks,
Chris

Last edited by cjk1026; 09-24-2007 at 01:28 PM.. Reason: added further info
Offline  
Old 09-24-2007, 11:08 PM   #11
John Clark
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,720
Default

It's going to take a OS upgrade. Even if Paul can get RIM to verify the problem, it'll take a while to get a fix made and even longer to get the OS out to us. It's going to give us trouble for a while.
Offline  
Old 09-27-2007, 09:59 AM   #12
spiroh
Knows Where the Search Button Is
 
Join Date: Dec 2006
Location: Chicago
Model: 8100
Carrier: T-Mobile
Posts: 30
Default

I have the same exact problem. Curve/AT&T 4.2.2.146
Offline  
Old 10-01-2007, 05:33 PM   #13
oneforall
New Member
 
Join Date: Aug 2007
Model: 8300
PIN: N/A
Carrier: ATT
Posts: 8
Default Bluetooth Problem

BlackBerry Curve 8300, OS 4.2.2.168. Blue Tooth Samsung WEP410 will go through pair up process, finds WEP410, asks to be connected, I say yes, the message then says waiting for WEP410 and hangs there. I hit espcape, look at the BT icon on the screen, the icon indicates that BT connection is there, but the WEP410 Ear Bud does not function. I am aiting for a solution.
Offline  
Old 10-02-2007, 09:10 AM   #14
slipsibm
Knows Where the Search Button Is
 
Join Date: Jan 2005
Model: 9800
Carrier: AT&T
Posts: 44
Default

Same problem with AT&T version of 4.2.x on an 8700c
Offline  
Old 10-03-2007, 03:24 PM   #15
pbaird
Knows Where the Search Button Is
 
Join Date: Apr 2005
Model: 8700g
Carrier: T-Mobile
Posts: 49
Default

Same problem here - 8700g and i-Blue gps puck. All versions of 4.2.1 from ATT and T-Mobile.

Specifically - The bluetooth connection drops, but the berry still thinks it is active. When it happens, I turn off bt, and turn it back on. That seems to fix it until the next use.

Last edited by pbaird; 10-03-2007 at 03:26 PM..
Offline  
Old 10-03-2007, 10:05 PM   #16
Starz26
Thumbs Must Hurt
 
Join Date: Jun 2005
Model: 8530
Carrier: Verizon
Posts: 55
Default Same issues

Bluetooth worked fine for me with the Kawbone headset and laptop connected via bluetooth.

Troubles started after adding the Bluetooth virtual keyboard from iTech.

I am now getting the same issues as described above. The headset randomly disconnects even though it shows connected. They keyboard only works once, then I have to reboot to get it working again.

I am using a BB8800.

sometimes I can get the keyboard to work after disabling the bluetooth and reenabling but not always. And even if that works I still have trouble with the headset.
Offline  
Old 10-07-2007, 03:37 PM   #17
pittwm
Knows Where the Search Button Is
 
Join Date: Sep 2007
Model: 8300
PIN: N/A
Carrier: ATT
Posts: 25
Default

Mine is Curve 8300 OS4.2.2.89 (186) with ATT.

Problem with my Holux Slim240. It work for a few days then quit working even though all indication on the BB said its pair and working properly.

Tried all sugessted method but cant get the bb and 240 to talk. I gave up on them.
Offline  
Old 10-14-2007, 03:34 PM   #18
y2ed
New Member
 
Join Date: Oct 2007
Model: 8320
PIN: N/A
Carrier: tmo
Posts: 2
Exclamation bb 8320

Hi guys i got the 8320 from tmobile os :4.2.2.171
i-Blue 737 bluetooth gps receiver
Will connect then i get searching for satalite.
I can get it to work by turning off the radio for my blackberry. This lets the gps work fine but then i cant download the maps. the radio being off also lets other bt devces connect better. I an track where Im going, how fast, get m position, ect,... but no maps will be downloaded. I figured it was because the phone is trying to do to much at one and is underpowered or my gps sucked. Let me know if this works for anyone else or of anyone else has tried this. Im very POed about this,.....
Offline  
Old 10-16-2007, 08:44 AM   #19
Paul Bowles
Thumbs Must Hurt
 
Join Date: Jul 2007
Location: Kent, UK
Model: Bold
PIN: N/A
Carrier: Orange
Posts: 83
Default

Quote:
Originally Posted by y2ed View Post
Hi guys i got the 8320 from tmobile os :4.2.2.171
i-Blue 737 bluetooth gps receiver
Will connect then i get searching for satalite.
I can get it to work by turning off the radio for my blackberry. This lets the gps work fine but then i cant download the maps. the radio being off also lets other bt devces connect better. I an track where Im going, how fast, get m position, ect,... but no maps will be downloaded. I figured it was because the phone is trying to do to much at one and is underpowered or my gps sucked. Let me know if this works for anyone else or of anyone else has tried this. Im very POed about this,.....
I'm really sorry but I found this very funny. Just had a picture of someone driving down a road switching the radio on and off on their Blackberry to get the maps/gps co-ordinates working (Sorry it really isn't funny and is very annoying, just painted a funny picture in my head ).

I'm going to give this a try and see if the same thing happens on the BlackBerry's I have here.

There is one other thing that I haven't confirmed yet but is worth investigating. This is that if you try to use a GPS unit with an effected BlackBerry before the unit has a satellite lock then the BlackBerry will more often not connect at all via Bluetooth. If you wait until you have a satellite signal first and then pair/connect the BlackBerry to it the connection seems to be more reliable.

I'm going to test this as well and while it would only help if your GPS unit will A) search for GPS data without being connected and B) has some sort of indicator to show when it has an active GPS signal it might at least provide a "work around" solution for some people (until hopefully the next OS release fixes the problem).
Offline  
Old 10-17-2007, 12:45 AM   #20
csoldfield
New Member
 
Join Date: Sep 2007
Location: Denver, CO
Model: 8300
PIN: N/A
Carrier: Cingular
Posts: 7
Default

I have the same issue with 8300/Curve v4.2.2.89 whilst running GoogleMaps (v1.6.1 #1616) or Nav4All (v8.0.3). Holux M-1200 puck.
Puck connects and stays connected flawlessly with Nokia N770/MaemoMapper. So I conclude the puck is good
However, with BlackBerry I get the bluetooth connection dropped. This can be after just a few minutes of launching the app, or maybe an hour. Pretty random intervals. Exiting (ie. Quit) then relaunching the app restores the BT connection. Deleting the pair and re-pairing is not necessary to restore the BT connection, nor does doing that help any.
Nav4All pops up a message: "The Nav4All application requires Bluetooth to be enabled. Enable Bluetooth? Yes/No" - select 'Yes' and after 45secs wait normal operation is always restored.
GoogleMaps simply stops flashing the little blue dot and pops up "Sorry, we can't determine your location at present". Sometimes it comes back by its self after a short while.
This issue seriously limits the usefulness of GPS on the Curve - on a recent roadtrip it naturally decided to fail at the most critical turn
Please, please, RIM can you fix this for us?
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

IBM 1337761 Genuine OEM Easystrike Correctable Ribbon Cassette - New Old Stock
$12.95
IBM 1337761 Genuine OEM Easystrike Correctable Ribbon Cassette - New Old Stock picture IBM OEM Parts Lot 
$200.0
 IBM OEM Parts Lot  pictureVintage IBM OEM Parts Lot (3)
$9.99
Vintage IBM OEM Parts Lot (3) pictureLot Of 5 IBM Easystrike Superior Write Correctable Ribbon #1380999 Lexmark OEM
$49.95
Lot Of 5 IBM Easystrike Superior Write Correctable Ribbon #1380999 Lexmark OEM pictureVintage IBM OEM Parts Lot (2)
$4.99
Vintage IBM OEM Parts Lot (2)  picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.