BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 04-30-2008, 01:13 PM   #1 (permalink)
dcp
New Member
 
Join Date: Apr 2008
Model: 8820
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default No wifi when turn off mobile data?

Please Login to Remove!

New 8820 yesterday on AT&T.

Was playing around with settings yesterday and when I set Mobile Network Options > Data Services to OFF I was able to browse using Wifi

Today when i do the same it shuts off Wifi as well.

Any ideas?

Thanks
Offline  
Old 04-30-2008, 01:23 PM   #2 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You mean it turns off the WiFi radio as well (WiFi logo disappears)?

Odd. Try to do a battery-pull and see if it fixes it. 1st step to take if device is having problems? - BlackBerryFAQ
Offline  
Old 04-30-2008, 01:48 PM   #3 (permalink)
dcp
New Member
 
Join Date: Apr 2008
Model: 8820
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yup - well doesn't disappear but definitely turns it off.

EDGE ---> edge

and WiFi goes light grey (from blue)

Battery pull doesn't fix
Offline  
Old 05-01-2008, 10:05 AM   #4 (permalink)
dcp
New Member
 
Join Date: Apr 2008
Model: 8820
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok - another discovery
If I turn off Mobile Network (i.e. AT&T data and voice connection turned off) WiFi works perfectly.
However if I turn off Mobile Network Data Serviecs it takes down WiFi.

Anyone figured a way around this?
I want to be able to selectively turn off BIS data when roaming internationally but still have phone and WiFi - right now it seems this is not possible.
Offline  
Old 05-01-2008, 10:48 AM   #5 (permalink)
BBFAQ Sysop
 
ricpac's Avatar
 
Join Date: Oct 2007
Location: Philippines
Model: 9700
OS: X 10.6
PIN: Alt+Shift+H
Carrier: GLOBE
Posts: 3,760
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Why don't you just set 'Data Services' to "Off When Roaming?"
Offline  
Old 05-01-2008, 11:01 AM   #6 (permalink)
dcp
New Member
 
Join Date: Apr 2008
Model: 8820
PIN: N/A
Carrier: AT&T
Posts: 13
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ricpac View Post
Why don't you just set 'Data Services' to "Off When Roaming?"
I could but presumably it'll have the same effect as manually switching it to "Off" now when I'm in coverage area and will shut off WiFi as well.

I'll certainly give that a go next week but I'm not optimistic.
Offline  
Old 11-27-2008, 12:20 PM   #7 (permalink)
New Member
 
Join Date: Nov 2008
Model: 9000R
PIN: N/A
Carrier: Rogers
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry to revive an old thread but did someone figure this out? I have the same issue on my Blackberry bold... When I turn off the data services, my wifi icon turns light grey and I cannot use it at all. If I check the status, it shows that it is connected though.

I want to make sure Data is not used at all when WIFI is available because I have a very limited data pkg. Services like MSN and GoogleTalk continue to use 3G even when I am on WIFI. Any suggestions?
Offline  
Old 11-27-2008, 01:17 PM   #8 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Turning data services off disconnects wifi data too. It's always been this way.
Offline  
Old 11-27-2008, 01:43 PM   #9 (permalink)
New Member
 
Join Date: Nov 2008
Model: 9000R
PIN: N/A
Carrier: Rogers
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

sooooo... no way for msn, gtalk and other apps to use wi-fi by default?
Offline  
Old 11-27-2008, 01:45 PM   #10 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

If you have a BB data plan, they should use wifi by default.
Offline  
Old 12-01-2008, 01:09 PM   #11 (permalink)
New Member
 
Join Date: Nov 2008
Model: 9000R
PIN: N/A
Carrier: Rogers
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm confused... Having a data plan enforces WIFI usage?

Is there a way for me to edit permissions for live messenger and BB Maps? I can only seem to set permissions for a few applications.
Offline  
Old 12-12-2008, 06:48 AM   #12 (permalink)
New Member
 
Join Date: Dec 2008
Location: Bucharest
Model: Bold
PIN: N/A
Carrier: Vodafone Romania
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same problem here,

So, the Wi-Fi works excelent if a have Data On.
If I shut down Data and try to connect via Wi-Fi doesn't work anymore.

So my question is why Wi-Fi doesn't work with Data shut off? It's not normal, for example even I'm in my country of origin I would like some times to het to Wi-Fi but I would like not to receive any data , when I'm outside my country is clear that it works on Data Off Roaming, but still...
Offline  
Old 12-12-2008, 03:06 PM   #13 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2005
Model: 8220
Carrier: WiFi hotspot
Posts: 1,009
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Open Manage Connections/Service Status.

If your device using WiFi, you'll see it listed.

Mine says:

Mobile Voice
Status: Available
Connection: WiFi (UMA)

BlackBerry Internet Service
Connection: WiFi

-------------------

Device should work without carrier cell service. To test:

Open Manage Connections
Uncheck Mobile Network
Make sure you have Checked WiFi

Open Service Status. Verify that your services do, indeed, on WiFi. You should be able to send and receive emails, browsing Internet and so on.



Most of problems people have with WiFi are related to the fact that device is smart to auto-switch between cell provider and WiFi - whichever is available. You may think your WiFi is working but if it really not - device will use cell service unless you explicitely tell it not to - through Manage Connections.
Offline  
Old 12-13-2008, 05:37 PM   #14 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2008
Location: Calgary, AB Canada
Model: 9000
PIN: N/A
Carrier: Rogers
Posts: 27
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vq35 View Post
Sorry to revive an old thread but did someone figure this out? I have the same issue on my Blackberry bold... When I turn off the data services, my wifi icon turns light grey and I cannot use it at all. If I check the status, it shows that it is connected though.

I want to make sure Data is not used at all when WIFI is available because I have a very limited data pkg. Services like MSN and GoogleTalk continue to use 3G even when I am on WIFI. Any suggestions?

Yeah, this is what I want to know as well. I don't want to use data as I have access to wi-fi at home. I want to make sure that when I do browse via wi-fi it won't switch over to 3G/Edge.
Offline  
Old 12-14-2008, 07:29 AM   #15 (permalink)
BlackBerry Extraordinaire
 
Join Date: Oct 2005
Model: 8220
Carrier: WiFi hotspot
Posts: 1,009
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

@ Redevil

Open Manage Connections
Uncheck Mobile Network
Make sure you have Checked WiFi


On Bold it'll also cut your phone off. Consider 8900 instead, it does UMA.
Offline  
Old 12-15-2008, 08:30 AM   #16 (permalink)
New Member
 
Join Date: Dec 2008
Location: Bucharest
Model: Bold
PIN: N/A
Carrier: Vodafone Romania
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Berry One View Post
-------------------

Device should work without carrier cell service. To test:

Open Manage Connections
Uncheck Mobile Network
Make sure you have Checked WiFi

Open Service Status. Verify that your services do, indeed, on WiFi. You should be able to send and receive emails, browsing Internet and so on.


Done that, still not working.
But my problem is that I would like to be ON carrier, OFF DATA and ON Wi-Fi.
It's not working and I personally find this a big disadvantage of this phone.
I'm very happy with my Bold but this problem is a major drawback for me
Offline  
Old 12-15-2008, 11:01 AM   #17 (permalink)
Knows Where the Search Button Is
 
Join Date: Oct 2008
Location: Calgary, AB Canada
Model: 9000
PIN: N/A
Carrier: Rogers
Posts: 27
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I think you have to go change your browser options to only use Hotspot Browser under Browser Configuration.

I also changed under General Properties>Default Browser> Hotspot Browser.

Now when I use the browser it shows that I am on wi-fi and not using the 3G data connection.

Hope that helps.
Offline  
Old 12-15-2008, 12:02 PM   #18 (permalink)
New Member
 
Join Date: Dec 2008
Location: Bucharest
Model: Bold
PIN: N/A
Carrier: Vodafone Romania
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thx but I already made this change, still the same problem
Offline  
Old 12-16-2008, 12:26 AM   #19 (permalink)
New Member
 
Join Date: Dec 2008
Model: 9000
PIN: N/A
Carrier: ATT
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

I am experiencing the same exact problem

If i turn mobile network off but leave Wifi on then its fine
This is no good because then I can browse the internet yet not receive phone calls or text in the process.

If i turn data off It will not let me use the internet at all via wifi

What I need is
WIFI = ON
DATA = OFF
NETWORK = ON

Any solutions? Please help
Offline  
Old 12-16-2008, 09:13 AM   #20 (permalink)
Knows Where the Search Button Is
 
BBbuddy's Avatar
 
Join Date: Feb 2008
Model: 9520
OS: 5.0.0.973
PIN: N/A
Carrier: T-Mobile & ePlus
Posts: 45
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by NYFan77 View Post
I am experiencing the same exact problem

If i turn mobile network off but leave Wifi on then its fine
This is no good because then I can browse the internet yet not receive phone calls or text in the process.

If i turn data off It will not let me use the internet at all via wifi

What I need is
WIFI = ON
DATA = OFF
NETWORK = ON

Any solutions? Please help
In general you must have data: on / off when roaming. When you are not in a BB-dataplan (BIS/BES) go to the TCP-config an delete everything there, else do what Mr. John Clark said here
__________________
BlackBerry make the man
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.