BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   WiFi HotZone (http://www.blackberryforums.com/wifi-hotzone/)
-   -   Wifi UMA on a browser secured network (http://www.blackberryforums.com/wifi-hotzone/128272-wifi-uma-browser-secured-network.html)

Krosfyah 05-04-2008 11:39 PM

Wifi UMA on a browser secured network
 
Is there a way to connect to a wifi network and get UMA working when that network requires you to enter a username/password via a browser first? I seem to run accross this all the time ...including my "guest" wifi network at work. I live near a university and they also have a guest wifi network that requires browser based authentication.

I've searched the forums and can't find a similar question. Maybe I don't know the right keywords to search.

I can make a successful connection to the access point and get an IP address. But the UMA part fails with an "ISP error".

John Clark 05-04-2008 11:45 PM

Yes. After it connects successfully, use the "Hotspot Login" button. There's even a bookmark in the Browser for "WiFi Hotspot Login."

Krosfyah 05-05-2008 05:42 PM

Well, I can now connect to our AP successfully and everything is fine except the UMA part. Are you sure UMA will work with this type of Access Point?

I found a link that said "Web Redirection" is not compatible with UMA. Can anybody confirm if UMA will work against an access point that requres authentication via a web browser?

I can authenticate using the method in the above post but only UMA doesn't work. :-(

John Clark 05-05-2008 05:45 PM

Yes, it does work on networks that require you to "accept" Terms of Service, even login with a password, etc. However, keep in mind that not all networks support UMA. There are lots of port settings, etc. that can block UMA functionality. TMobile/RIM don't claim that it works on every network.

Krosfyah 05-05-2008 07:56 PM

well, crapola. I just walked over to a "web redirected" hotspot by the house and was able to get on with UMA just fine with your technique.

So the one place in the whole world I want it, at work, I can't get it. They just setup a guest wifi which works great for unsecured browsing ...but no UMA. :cry:

Thanks for your help.

John Clark 05-05-2008 09:03 PM

Certain ports need to be opened for UMA. You might talk to the IT department and see if it's something they can do. Ports 500 and 4500, if I remember correctly, as well as IPSec need to be enabled. Look in Main Page - BlackBerryFAQ under the wifi section for what is required. Take it to your IT department and see what they can do for you.

BryanS 08-26-2008 07:59 PM

getting closer
 
I've gotten the browser login screen on my 8320 where it will let me login to my college's wifi and I can successfully enter the info and authenticate. I am not able to get UMA service and when I run the wifi diagnostic I get a green check in the "UMA Wi-Fi Available" box but I get the red x in the "Connection" box. I'm getting an error code of W006.1 and a status of "ISP or T-Mobile Network error".

Would this have to do with the ports for UMA being blocked on the network or is there something that I can do to get this stuff working?

shlomibiz 10-01-2008 05:08 PM

I have the same problem, I get error W006.1 and sometimes it's W006.2, I have updtaed te 911 address in my profile, opened the ports 500 and 4500, but I am not sure how to enable IPSEC, please help

lacroixn 10-05-2008 07:40 PM

I had the same problem as you guys, 8120 but cannot get uma at work. I have tried everything. Most likely due to port settings that IT may not want to reset for the few individuals with wifi phones.

Solution, I created my own access point on the job. I purchased a portable dlink(pocket router) wireless router $40.00. I now can make free calls all day at work and free calls all day at home. On vacation I carry the router with me to create my wireless access point.That $40.00 dollars is well worth it. My job phone does not allow long distance calls, my 8120 can call all over the US free of charge.

GMikeW 10-25-2008 09:44 AM

Login page doesn't work
 
This thread has helped me greatly, but I'm not there yet. I can get to my job's login site where I have to check a box saying I'm 18. On a laptop, that would enable an "enter" button which would allow access when clicked. For some reason, this doesn't happen. The button never goes from faint to bold. I have tried everything I can think of. Any suggestions?

rachamphetamine 10-25-2008 11:12 AM

You may need to enable javascript if you don't already have it enabled.

GMikeW 10-25-2008 03:13 PM

Where is that?

stufried 10-29-2008 10:11 AM

Have any of you looked at Devicescape which is free wifi client that stores the settings for many networks and you can add your own personal info online?


All times are GMT -5. The time now is 02:34 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.