BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 06-05-2008, 03:02 PM   #1 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Post New BB User: Some WIFI questions

Please Login to Remove!

i just got my first blackberry curve from T-Mobile. After one day of searching over internet, i finally got the wifi connection working. it was definitely not an easy task. well, i do have some questions left open.

this is my situation:
live in a t-mobile roaming area (cell one coverage, now part of ATT). Home wireless network setup using linksys WRT54GS v7.2 with WPA. Office wireless network with no security, but needs to sign on to a login webpage in order to access internet.

i only have a 9.99 BB email plan.

when i first received the device yesterday, i turned off the data services option (in manage connections->mobile network option), because i don't want to be charged for using edge. my attempts to connect either home or work wireless network were failed (error code W002). However, i did see the "WIFI" icon in bold with red bars and lowercase uma at home, while the "WIFI" icon was in gray at work. in both cases, the browser didn't work (i've changed the option to wifi preferred ). but i was able to make a phone call over uma at home, because the call is marked as "U", which means it's a hotspot@home call.

today, i turned on the data service option, then everything went through smoothly, although i still got error code W002 , and the "WIFI" icon is still in gray at office.

so here are my questions:
1. does the data services option controll both edge and wifi data?

2. in order to determine if the data's coming from edge or wifi, i turned off the mobile network connection. and the internet function was not affected. does it imply the data is coming from wifi (i really don't want to be charged)?

3. if i cancel the email plan later, will i be able to access the internet?

4. since i don't have a hotspot@home service, the UMA call will be counted as regular plan mins, right? (i saw the discussion on the forum, just want to reconfirm that)

5. why am i getting error codes and gray WIFI icon, but can still access the web? is it a software bug?

Thanks.
Offline  
Old 06-05-2008, 03:59 PM   #2 (permalink)
Thumbs Must Hurt
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: fido
Posts: 52
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

1. i think the data services option controls EDGE(wap) and not edge(network signal) and it does not control the wifi(i think)

2. to determine if your phone is connceting from wifi or something else, EDGE will appear if you are using phone's internet. Wifi will appear if it's on and it shuold say T-mobile - "wireless network name"

3. if you cancel the email you can still access internet but from wifi only

4. yes it will but you will have to have the UMA option from T-mobile added on

5. if you are able to access the web and you haven't connected to a wifi access point, then i think you are using the phones internet...

If i am wrong in any of these responses, please correct me
Offline  
Old 06-05-2008, 06:20 PM   #3 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

if i disable data service, the browser will not load. does it mean i'm actually using EDGE?


i just talked with a tmobile CSR. he told me if i have no data plan, i will not be able to access internet via mobile network (i.e. EDGE). so i'm confused...
Offline  
Old 06-17-2008, 04:11 PM   #4 (permalink)
New Member
 
Join Date: Jun 2008
Model: 8120
PIN: N/A
Carrier: Tmobile
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I definitely have the same problem. I was wondering, is there anyway to download another browser? This way, Tmobile might not be able to block WIFI internet access to certain pages. Just a thought
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.