BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-09-2009, 10:53 PM   #1 (permalink)
New Member
 
Join Date: Nov 2009
Model: 9700
PIN: N/A
Carrier: Bell
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default BB 9700 Wifi connection

Please Login to Remove!

Hello,

I am not able to access the internet with my wifi connection. When I look in my router client's list, I see my phone MAC address is connected. I can also confirm the IP address in both my phone and router. The SSID name appear on my phone. When I go in Manage Connections, I see a blue checkmark beside Wi-Fi, followed by my SSID shown in Green, but at the right end side, there is an indent (-). I think I should see a checkmark instead this indent.

I am sure that if I would have that checkmark, when I would go on internet, I would see the Wifi icon white instead of grey.

Can someone can explain why this happen and what I should set to see that checkmark?

Thank you!
Offline  
Old 11-10-2009, 10:39 AM   #2 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default

1. Do you have a Blackberry data plan?
2. Are your data services turned on?
__________________
My other Blackberry is a PlayBook.
Offline  
Old 11-10-2009, 10:57 PM   #3 (permalink)
New Member
 
Join Date: Nov 2009
Model: 9700
PIN: N/A
Carrier: Bell
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a data plan, but I am not sure what you mean by data service on. Can you tell me how to proceed to activate it on my phone? I will see this way if it is done already.

Thank you!
Offline  
Old 11-11-2009, 09:42 AM   #4 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,709
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

Wirelessly posted (8820)

I won't be much help because wifi worked for me right off the bat and always has. But when someone here asks if you have a blackberry data plan, they mean a blackberry data plan, not just a regular data plan. You must contact your service provider to have the plan activated.

I don't know about the thing you are calling an indent. From what I'm familiar with, if you have a green checkmark, your connection is in place.

If you do not have a blackberry data plan, you will not have use of blackberry branded data applications. I'm not sure if you have the hotspot browser without a blackberry data plan or not. But open whatever browser you have and see if you can change to wifi or hotspot browser in browser confirguration options.

I have seen posts on the forum that explain the way the wifi icon changes based on connection status. I can't recall everything exactly, but I think it should be easy enough for you to find if you search or scan down through the posts.

Good luck. If you don't have a blackberry data plan, I recommend it.
__________________
- Ira
Offline  
Old 11-11-2009, 11:02 AM   #5 (permalink)
BlackBerry Master
 
Trimix's Avatar
 
Join Date: Apr 2008
Location: smelLA, caLAMEfornia
Model: 8320
OS: 4.5.0.182
PIN: infarina
Carrier: of alotta bacteria
Posts: 4,932
Post Thanks: 1
Thanked 6 Times in 6 Posts
Default

Wirelessly posted (Tmo's cheapest BB customer)

Re: data services turned on/off - Manage connections>Mobile network options
Offline  
Old 11-11-2009, 11:08 AM   #6 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Quote:
Originally Posted by aiharkness View Post
I have seen posts on the forum that explain the way the wifi icon changes based on connection status.
There are two levels to Wi-Fi connectivity:
  1. If you are connected to Wi-Fi, the name assigned to the Wi-Fi profile will show up at the top of the home screen next to the Carrier branding. For example, my phone shows AT&T - Office at the top of the home screen.
  2. Once connected, you can determine if you are connected to the BlackBerry infrastructure by looking at the Wi-Fi logo on the home screen. If the logo is gray, you are not connected to the infrastructure. If the logo is white, you are connected.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 11-11-2009, 11:13 AM   #7 (permalink)
BlackBerry God
 
aiharkness's Avatar
 
Join Date: Jul 2005
Location: Florida Panhandle
Model: Z10
OS: 10.2.1
Carrier: T-Mobile USA
Posts: 13,709
Post Thanks: 15
Thanked 498 Times in 485 Posts
Default

Wirelessly posted (8820)

EDIT: Disregard what I wrote below. In my case, with tmobile, with the mobile network off and wifi on, I have UMA and I see T-Mobile as well as the local wireless network name. I believe when I lose UMA for whatever reason, I no longer see T-Mobile and just see the wireless network name.

----------------
Thanks for the assist!



You will not see the mobile network if you have turn off mobile network, right. In oherwords, in your example, if wifi is on and everything else is off (or you are not connected to AT&T), then you would only see office. Right?
__________________
- Ira

Last edited by aiharkness : 11-11-2009 at 11:17 AM.
Offline  
Old 11-11-2009, 11:16 AM   #8 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Correct. I just turned off Mobile Network, and so all that shows now on the home screen is Office. The logo is still white meaning that I am still connected to the BlackBerry infrastructure. Everything works as expected minus (obviously) cellular services until I turn Mobile Network back on.
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 11-13-2009, 06:39 AM   #9 (permalink)
New Member
 
Join Date: Nov 2009
Model: 9700
PIN: N/A
Carrier: Vodafone
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am having issues with my Wi-Fi aswell.
The name of my router comes up but the Wi-Fi symbol keeps changing from Grey to White constantly.
I have checked with my provider and my BIS is all OK and my handset is registered.
If i turn the mobile connection off and the Wi-Fi symbol isn't white then i cannot get onto the internet.
Will this be a problem with my router?
Many thanks in advance
Offline  
Old 11-13-2009, 07:59 AM   #10 (permalink)
BlackBerry Extraordinaire
 
Join Date: Jan 2006
Model: LEZ10
OS: 10.0.10
Carrier: Rogers CA
Posts: 1,704
Post Thanks: 20
Thanked 77 Times in 68 Posts
Default

When the Wi-Fi symbol is gray it means that the Blackberry can not connect with the RIM servers. The problem could be with your Blackberry, router, your ISP, the Internet or RIM. Usually if the problem isn't with your router there is someone else looking at it, so if the problem persists, I would suspect your router/Blackberry.
__________________
My other Blackberry is a PlayBook.
Offline  
Old 11-13-2009, 09:03 AM   #11 (permalink)
Magic Bananas
 
ifonline's Avatar
 
Join Date: Jan 2006
Location: Braselton, Georgia
Model: iP4S
OS: 5.1
Carrier: Verizon
Posts: 2,350
Post Thanks: 1
Thanked 54 Times in 45 Posts
Default

Quote:
Originally Posted by wrightyrs View Post
If i turn the mobile connection off and the Wi-Fi symbol isn't white then i cannot get onto the internet.
That's because you aren't connected to the BlackBerry infrastructure when the symbol is gray.

Quote:
Will this be a problem with my router?
If you have no data issues when not connected to Wi-Fi, and only have issues when you are connected to Wi-Fi, then my first thought is that this is a router issue.

Since I don't have a 9700, I don't know for sure. Do you know if anyone else is having this issue?
__________________
Ian

Semper Fi 3/2/2
"Wow" is now overused. Therefore, I will use "Magic bananas" instead.
Offline  
Old 11-22-2009, 05:29 PM   #12 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Feb 2006
Location: Baton Rouge, La
Model: 9810
Carrier: AT&T
Posts: 261
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I know on firmware 5.0.0.344 I had a problem with my 9700 on WiFi. If I was moving from one AP to another AP (like from home to office) the dns info was cached. Fixed with 5.0.0.351.

A quick check is to reboot the phone. Or goto Connections, WiFi Options, Blackberry button, DNS Lookup, then Blackberry button again and select Clear DNS Cache. Disconnect from WiFi then try again.

Last edited by vhato : 11-22-2009 at 05:31 PM.
Offline  
Old 04-06-2010, 03:56 AM   #13 (permalink)
New Member
 
Join Date: Sep 2008
Model: 9700
PIN: N/A
Carrier: Rogers
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vhato View Post
I know on firmware 5.0.0.344 I had a problem with my 9700 on WiFi. If I was moving from one AP to another AP (like from home to office) the dns info was cached. Fixed with 5.0.0.351.

A quick check is to reboot the phone. Or goto Connections, WiFi Options, Blackberry button, DNS Lookup, then Blackberry button again and select Clear DNS Cache. Disconnect from WiFi then try again.
All this stuff didn't work but as soon as i made the Wireless N router do only B and G and disabled N it connects to Wifi, i think this is the solution for some people.

I don't need Wifi for anything but the phone so disabling N is no big deal.
Offline  
Old 04-06-2010, 11:13 AM   #14 (permalink)
New Member
 
Join Date: Apr 2010
Model: 9700
PIN: N/A
Carrier: orange uk
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im going to be completley hopeless here... Where do I post a thread about WI-FI issues im having? Im trying to connect my 9700 Bold to another PC via a wirless network (Its so I can use VNC+). When I view wireless networks I see the one I want but it wont connect. It just tells me that it cannot find the ip address.

Other friends using an iphone and a Sony erricson can connect fine. But my Bold refuses.... Sees network, WONT CONNECT.... Please help, its doing my noodle in...

Sorry if this is in the wrong place... No idea where to post it...

Thanks
Offline  
Old 06-01-2010, 05:06 AM   #15 (permalink)
New Member
 
Join Date: May 2010
Location: Hong Kong
Model: 9700
PIN: N/A
Carrier: PCCW Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have similar problem with my BB9700. I can use wifi in office and free wifi hotspots provided by the carrier without any problem.

I could connect to my wifi at home, however, the connection drops every time just after a successful connection. But, other equipments i.e. desktop, notebook are ok.

It seems that both my home router and BB are working fine with other equipment. But, they are just not compatible with each other. The brand of my router is Buffalo G300N.

I searched all possible websites over the world can try to solve the problem. After about 1 more month searching and test. I finally locate the problem. The problem is at the "router setting".

In Buffalo, the default setting for channel is "auto". This is the root of the problem. When there is interference around, the channel will switch for a better one, then the connection would drop since the reception of BB is not stronger than desktop and notebook. How to solve it? Try to switch the "auto channel" function to "manual". Let say, Channel 1, if it is not perfect, try channel 6 and 11. After that, my problem got fixed. Trial and error are very painful and time consuming. Hope these could help. From BB User in Hong Kong
Offline  
Old 06-04-2010, 09:16 AM   #16 (permalink)
Knows Where the Search Button Is
 
mmbawlz's Avatar
 
Join Date: Aug 2009
Location: Toronto
Model: 9700
OS: 5.0.0.862
PIN: N/A
Carrier: Rogers
Posts: 26
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Use pre shared key, it worked for me
Offline  
Old 09-19-2010, 11:35 AM   #17 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: Maxis
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I do not have a data plan.
I was fiddling with my BB 9700 whilst trying to connect to the wifi at home
I came to a point whereby I can only connect if my Mobile Network is turned off. If its on, i can't connect to wifi.

Did i screwed up some settings?


Thanks for the responds.
Offline  
Old 09-21-2010, 02:20 AM   #18 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: depending the country
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Guys,
I think I have the weirdest problem of all,
I have different sim cards for whenever I travel between Canada, Europe, Middle east and China. My problem is that in the middle east some countries don't have a blackberry service, so my only way to get my emails and use my BBM was to connect via WIFI, all was working well till yesterday, when i went from a country with a blackeberry service to one with no blackberry service. In the morning the WIFI connection was working then all stoped in all WIFI areas, Home, Work and caffees.
this is what I'm getting, My BB 9700 is connected on the networks but still have the (-) on my WIFI status. and can't connect to the internet or send any BBMs and emails.

I tried a battery reboot, a soft reboot, a double soft reboot. I also changed the net work to HOTSPOT but nothing seems to work. I even switvhed SIM cards from my various ones that have a BB plan but nothing worked.
Any suggestions??
Thank you.
Offline  
Old 10-04-2010, 05:04 PM   #19 (permalink)
New Member
 
Join Date: Sep 2010
Model: 9700
PIN: N/A
Carrier: o2
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by wrightyrs View Post
I am having issues with my Wi-Fi aswell.
The name of my router comes up but the Wi-Fi symbol keeps changing from Grey to White constantly.
I have checked with my provider and my BIS is all OK and my handset is registered.
If i turn the mobile connection off and the Wi-Fi symbol isn't white then i cannot get onto the internet.
Will this be a problem with my router?
Many thanks in advance
Hi guys

im having this very same issue, while at work and other hotspots my BB connects without a hitch yet at home the wifi symbol changes from grey to white constantly. Im with talktalk uk and they suggested changing the channel but ive been through them all without any luck! we have 2 laptops connected successfully to the router and all my past phones have connected so i dont understand why im having problems this time. any ideas???

thanks in advance

BB9970
v5.0.0.862 (platform 5.1.0.175)
O2 uk simplicity for Blackberry
Offline  
Old 10-05-2010, 10:44 AM   #20 (permalink)
CrackBerry Addict
 
Klotar's Avatar
 
Join Date: May 2007
Location: Winnipeg MB Canada
Model: 9700R
OS: 7.1.0.190
PIN: On Request
Carrier: Rogers Wireless
Posts: 902
Post Thanks: 0
Thanked 1 Time in 1 Post
Default

I tried a number of things to stabilize my wifi connection, including a new router (which made no difference out of the box going from a LinkSys to D-Link).

I believe that changing the following solved the issue for me:

- set wireless from a/b/g/n to g-only

- set autoscan channels off, I used channel 5.

- reduced beacon frequency from 100 (default) to 50.

- set channel width from 20/40 Auto to 20.

- set SIP ALG off and SPI off (I have VoIP phones on the network).

I had tried a number of other things, including reserving and assigning static IP's, MAC Filtering, switching from WPA2 to WPA, changing encryption from TKIP/AES to TKIP only, etc., but I believe the 4 or 5 items I listed made the difference. Yes, I do realize the possible risk of turning SPI off but in my case, I believe it to be minimal.
__________________
-Klotar
Supervising Manager of the Department of Redundancy Department.
BlackBerry Certified Support Specialist
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.