BlackBerry Forums Support Community

BlackBerry Forums Support Community (http://www.blackberryforums.com/)
-   WiFi HotZone (http://www.blackberryforums.com/wifi-hotzone/)
-   -   Blackberry infrastructure connecting error? (http://www.blackberryforums.com/wifi-hotzone/260583-blackberry-infrastructure-connecting-error.html)

jpb39 07-18-2012 05:29 AM

Blackberry infrastructure connecting error?
 
I have an 8900 connecting to a WiFi network on home router with WPA2 security. The network shows up as active under Services Status and LogicMail can send and receive over the network when it is set up to use WiFi only. However, the WiFi logo is 'grey', the connection status is a 'dash' rather than a 'check', both reflecting the fact that the Blackberry infrastructure returns a connection error when attempting to access BIS via the WiFi connection.

The 8900 is on a data plan, with data enabled. At some point in the past, it connected to BIS via WiFi. A 9700 with the same provider has no difficulty accessing BIS over the same network. I have tried different versions of the 8900 OS, and deleted the Wi-Fi TCP/IP Transport [WPTCP] service book.

Thanks for any suggestions.

JPB

Dubdub 07-18-2012 07:57 AM

Re: Blackberry infrastructure connecting error?
 
Have you called your cell carrier "Giffgaff" to make sure that the Blackberry data plan is active?

Have you tried resending service books (see the FAQ)?

Have you tried a battery pull?

jpb39 07-18-2012 10:17 AM

Re: Blackberry infrastructure connecting error?
 
Thanks for the quick reply. I've tried everything I could think of: (re)installing the latest OS, rolling back to the last version supported by the local operator, installing a hybrid with components from later OS versions, deleting the WiFi service books, asking the network to resend the full set of service books, scanning for the network and also manually adding it, changing the router password and security setting. And of course lots of battery pulls along the way.

There may be an incompatibility with the router (an Apple Airport Extreme running an 802.11n network in b/g compatibility mode) or possibly the channel automatically selected by the router. The odd thing is just that LogicMail in WiFi mode happily connects (and fails once WiFi is disabled), so it is somehow the infrastructure connection that is problematic.

JPB


All times are GMT -5. The time now is 12:46 PM.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.