BlackBerry Forums Support Community
              

Closed Thread
 
Thread Tools
Old 05-24-2007, 09:49 AM   #1
mahoward
CrackBerry Addict
 
mahoward's Avatar
 
Join Date: May 2005
Model: 8900
Carrier: T-Mobile
Posts: 560
Default BESD 4.0 / 4.1 Interoperability Issues

Please Login to Remove!

OK, so I upgraded one of my main BES servers to 4.1 SP3 HF1 last weekend, but left the other two at 4.0 SP6 HF4. Since the DB Schema was upgraded, we needed to upgrade all of our BB Manager workstations to 4.1 as well.

Now, we are seeing an issue where, using the locally installed 4.1 Manager, we cannot provision a new user added to one of the 4.0 servers using the USB cable. The service books get assigned but the rest of activation / synchronization / prepopulation does not kick off. Wireless activation of new users on the 4.0 servers also seems erratic.

BTW, this upgrade was performed after getting the word at WES that 4.0 and 4.1 servers sharing the same SQL database is OK, since they have many larger accounts than ours and they can't expect them to upgrade 10's of servers at the same time.

Well apparently it is OK for existing users but not newly added users! RIM's official response now is: Well it can work but it is not recommended, and the "workaround" is to upgrade the remaining servers to 4.1.

I don't know why RIM still thinks we are all 10 user companies that can do whatever we want, some of us actually have to plan for these things and schedule them during monthly maintenance windows.

OK, enough rant. Just wanted to get the word out to any other Domino folks that are still contemplating moving multiple servers from 4.0 to 4.1.
__________________
BESX 4.1.7 on Exchange 2003: 65 Devices
BESX 5.0.3 on Exchange 2003: 2007 Devices
Offline  
Old 05-24-2007, 09:56 AM   #2
x14
BlackBerry Extraordinaire
 
Join Date: Jul 2005
Location: NYC
Model: 9800
OS: 6.0.0.546
Carrier: AT&T
Posts: 2,344
Default

During my BES 4.0 -> 4.1 testing I had 1 BES 4.0 and 1 BES 4.1. Existing users on BES 4.0 were fine and I could move users from BES 4.0 to BES 4.1. I had a lot of problems adding users to BES 4.0.

I stopped adding users to BES 4.0 and I ran thru upgrading to BES 4.1 ASAP.
__________________
Exchange 2007/BES 5.0.2 MR2
Offline  
Old 05-24-2007, 10:18 AM   #3
AlanM
Talking BlackBerry Encyclopedia
 
AlanM's Avatar
 
Join Date: May 2005
Location: Huntsville, AL
Model: 9930
Carrier: Verizon
Posts: 335
Default

Wow, I wonder if the same issue exists with Exchange. On my upgrade path I don't really see us adding more to the 4.0.
__________________
AlanM
Exchange\Blackberry Admin
4 - BES Servers (5.0.3),
~1500 BB Users, and a headache.
War Eagle!!
Offline  
Old 05-25-2007, 09:10 AM   #4
mahoward
CrackBerry Addict
 
mahoward's Avatar
 
Join Date: May 2005
Model: 8900
Carrier: T-Mobile
Posts: 560
Default

Quote:
Originally Posted by x14 View Post
During my BES 4.0 -> 4.1 testing I had 1 BES 4.0 and 1 BES 4.1. Existing users on BES 4.0 were fine and I could move users from BES 4.0 to BES 4.1. I had a lot of problems adding users to BES 4.0.

I stopped adding users to BES 4.0 and I ran thru upgrading to BES 4.1 ASAP.
Thanks x14, good information but a little too late for me. I wish RIM had highlighted issues like this so I didn't look stupid for getting bit by this. Upgrading in stages is the only way to do it in a large environment so I didn't really have any choice anyway.

On top of all this the local BB admins are starting to complain about the 4.1 interface being more difficult to use. So you get new features but with less usability.
__________________
BESX 4.1.7 on Exchange 2003: 65 Devices
BESX 5.0.3 on Exchange 2003: 2007 Devices
Offline  
Old 05-25-2007, 09:29 AM   #5
noname
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Default

I have experienced devices with handheld software version 4.2 (e.g. Pearl, 8800 etc.) not able to EA if I added these newer devices on a BES 4.0. I have a mixed BES 4.0 & 4.1 are in the BlackBerry Domain.

RIM tech advised to only add newer 4.2 devices on BES 4.1 instead of BES 4.0. I guess BES 4.1 is specifically built for 4.2 devices and when our BESes are mixed and database schema is upgraded, functions such as EA is stuck due to "unrecognized data format" as older devices are not able to reconcile them. Hence I would also recommend only adding newer devcies on a 4.1 BES and not 4.0 BES.
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 05-25-2007, 09:43 AM   #6
mahoward
CrackBerry Addict
 
mahoward's Avatar
 
Join Date: May 2005
Model: 8900
Carrier: T-Mobile
Posts: 560
Default

Thanks for the info noname, since I instructed our admins to setup all new devices on the 4.1 server due to the other issue, this would be covered.

It may also resolve some previous issues I was unaware of however, good info!
__________________
BESX 4.1.7 on Exchange 2003: 65 Devices
BESX 5.0.3 on Exchange 2003: 2007 Devices
Offline  
Old 05-25-2007, 09:45 AM   #7
noname
BlackBerry Extraordinaire
 
noname's Avatar
 
Join Date: Sep 2005
Location: Congested Islet of "Foreign Talents" (> 45% of workforce) - Singapore.
Model: Z10
OS: 10.0.0
PIN: NUKE(PAP)
Carrier: Singtel
Posts: 1,504
Default

anytime, mahoward. btw i like your besdomino blog. Lots of interesting and good information too. Excellent work!
__________________
Native but 4th class citizen of a nation governed by idiots who import congestions & contention.
Offline  
Old 05-25-2007, 10:20 AM   #8
mahoward
CrackBerry Addict
 
mahoward's Avatar
 
Join Date: May 2005
Model: 8900
Carrier: T-Mobile
Posts: 560
Default

Thanks noname, your check is in the mail.
__________________
BESX 4.1.7 on Exchange 2003: 65 Devices
BESX 5.0.3 on Exchange 2003: 2007 Devices
Offline  
Old 06-01-2007, 02:36 PM   #9
mahoward
CrackBerry Addict
 
mahoward's Avatar
 
Join Date: May 2005
Model: 8900
Carrier: T-Mobile
Posts: 560
Default

Update 6/1/07: Apparently the tech I spoke with on this issue was incorrect, RIM verifies that they fully support a mixed 4.0/4.1 environment as they told me at WES just a few weeks ago.

This issue with USB activation has to do with an identified bug in the 4.1 SP3 BlackBerry Manager console, which is fixed in the upcoming 4.1 SP4, but also can be worked around by downgrading to the 4.1 SP2 Manager console.
__________________
BESX 4.1.7 on Exchange 2003: 65 Devices
BESX 5.0.3 on Exchange 2003: 2007 Devices
Offline  
Old 06-01-2007, 11:08 PM   #10
gziz
Talking BlackBerry Encyclopedia
 
Join Date: Jun 2006
Model: 8700c
Carrier: cingular
Posts: 204
Default

i believe that you can assign 4.0 users fine if you use the blackberry legacy manager instead of the 4.1 blackberry manager, in exchange anyway.
Offline  
Old 12-03-2007, 10:03 PM   #11
yo_fishy
Knows Where the Search Button Is
 
yo_fishy's Avatar
 
Join Date: Nov 2006
Location: NJ
Model: 8310
OS: 4.5.0.110
Carrier: AT&T
Posts: 15
Default Unable to EA when removing/re-adding

I'm running into a similar issue. I upgrade one of our BES servers to 4.1.4 MR2while the other three are running 4.0.7 as I to did not want to upgrade all servers at the same time being in a big corporate environment. I don't have an issue adding new users to any BES server be it 4.0 or 4.1. If I remove someone from one of the remaining 4.0 servers and attempt to add them onto another server or the same server as a troubleshooting step, I can't get the BB to EA. Under IT Policy on the Blackberry Manager I receive the error that reads, "Processing stopped: Invalid Pin". It also seems that I have to purge the users manually inside the users pending delete queue as they do not on their own. The SQLServerAgent service is running on the SQL server.

Has anyone ran into anything like or have any suggestions? This happened late today so I don't have all the information like what type of device, OS, etc. It happened to the first 2 users that were removed and re-added as they were having send/receive issues so I'm just assuming this isn't a coincidence. I will continue to trouble shoot tomorrow. Any help is appreciated as always.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Vape Rainbow picture

Vape Rainbow

$15.00



USB TL866II Plus Programmer EPROM EEPROM Flash MiniPro BIOS AVR AL PIC SP MCU picture

USB TL866II Plus Programmer EPROM EEPROM Flash MiniPro BIOS AVR AL PIC SP MCU

$58.50



Fake Solar Car Alarm Led Light Security System Warning Theft Flash Blinking ABS picture

Fake Solar Car Alarm Led Light Security System Warning Theft Flash Blinking ABS

$6.99



Aluminum Trim Coil 24

Aluminum Trim Coil 24" x 50' Royal Brown White Flashing New ATC24-BR Roll Roof

$84.85



20Pcs 1.8mm 2mm 3mm 5mm 8mm 10mm Pre Wired LED DC9-12V Lights Emitting Diodes picture

20Pcs 1.8mm 2mm 3mm 5mm 8mm 10mm Pre Wired LED DC9-12V Lights Emitting Diodes

$6.99



32G Voice Activated Mini Spy Digital Sound Audio Recorder Dictaphone MP3 Player picture

32G Voice Activated Mini Spy Digital Sound Audio Recorder Dictaphone MP3 Player

$26.49







Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.