BlackBerry Forums Support Community
              

Closed Thread
 
Thread Tools
Old 09-29-2008, 09:51 PM   #1
fedfan
New Member
 
Join Date: Sep 2008
Model: 8700g
PIN: N/A
Carrier: pldt
Posts: 4
Default Help Please - new to BB MDS Studio

Please Login to Remove!

Hello

I just started using BB MDS Studio for developing applications with web services. As a start, I followed the steps from the documentation (Blackberry MDS Studio Version 4.1.3 Getting Started Guide). I was able to recreate the length conversion application example using both Quick-Start and Bottom-Up approach and when I test both on the BB Device Simulator, I am able to submit my request and the 'Message Sent' dialog appears, but the problem is, I get no response (the Response Screen does not show.. after pressing the 'Ok' button on the 'Message Sent' dialog, I am back at the main/first screen)

Also, I tried adding debug messages to the scripts using Debug.write("test message") but I can't see my messages at the test console.

I hope someone can help me.
Thanks
Offline  
Old 10-02-2008, 08:55 PM   #2
brcewane
Thumbs Must Hurt
 
Join Date: Aug 2007
Model: 8100
PIN: N/A
Carrier: Rogers
Posts: 140
Default

Make sure you have assigned a JavaScript funtion to your return event for the Response Message. All messages (Request/Response) are asynchronous, so the code to open the new screen needs to be in the event for when the message Response arrives at the device.

Also, make sure your webservice doing the conversion is up and running and is actually processing the message and returning a response.
Offline  
Old 10-02-2008, 09:52 PM   #3
fedfan
New Member
 
Join Date: Sep 2008
Model: 8700g
PIN: N/A
Carrier: pldt
Posts: 4
Default

I tried creating another application, it seems to be working fine and the debug messages appear at the test console.. but after I send, I get an error: An Error has occurred, CONNECTOR_ERROR Forbidden

so I edit rimpublic.property because I am working behind a proxy, but after I do that, my application still doesn't work and my updates on the scripts/screen don't reflect.. when i revert rimpublic.property though, my updates on the codes are reflected, but I'm back to my original problem, which is with the proxy I guess.. how do I get MDS Studio and the service to run behind a proxy?
Offline  
Old 10-03-2008, 08:46 AM   #4
brcewane
Thumbs Must Hurt
 
Join Date: Aug 2007
Model: 8100
PIN: N/A
Carrier: Rogers
Posts: 140
Default

This should help: Livelink - Redirection
Offline  
Old 10-05-2008, 08:31 PM   #5
fedfan
New Member
 
Join Date: Sep 2008
Model: 8700g
PIN: N/A
Carrier: pldt
Posts: 4
Default

thanks brcewane
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

GODINGER SILVER CRYSTAL HANDLE CAKE KNIFE/SERVER EXCELLENT
$4.95
GODINGER SILVER CRYSTAL HANDLE CAKE KNIFE/SERVER EXCELLENT pictureHP JetDirect 170X J3258B-61012 External Print Server
$23.62
HP JetDirect 170X J3258B-61012 External Print Server pictureServer with Spout Warmer Hot Nacho Cheese Food
$250.0
Server with Spout Warmer Hot Nacho Cheese Food  picture Server Waitress Apron Nightmare After Teacher Novelty Name FREE Lady Pizazz
$16.0
  Server Waitress Apron Nightmare After Teacher Novelty Name FREE Lady Pizazz picture Server Waitress Apron Nightmare After Teacher Novelty Name FREE Lady Pizazz
$16.0
  Server Waitress Apron Nightmare After Teacher Novelty Name FREE Lady Pizazz picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.